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1 Before You Begin 

1.1 Who Should Use This Manual 
This manual is for system administrators responsible for installing, configuring and using the 
eLux Image Administration Service (ELIAS) to create image definition files for Thin Clients 
running Embedded Linux eLux® NG or eLux® RL. This manual assumes knowledge of: 
• operation of network and asynchronous communication hardware, including serial ports 
• the operating system (OS) on the client computer. 

1.2 About This Guide 
Starting with installing the image definition file editor ELIAS, this documentation presents step-
by-step directions on how to perform a firmware update. For convenience, the manual is divided 
into the following sections: 
 

Chapter Description 
1 Before You Begin Manual conventions, overview of ELIAS  functions and 

features 
2 Installing ELIAS  and 

Container 
System requirements and detailed instructions on how to 
install ELIAS  and the software container 

3 Introducing the ELIAS  
Interface 

An overview of the ELIAS  main screen 

4 Defining an Image 
Definition File 

How to use the program ELIAS  to create an image definition 
file  

5 Working with Containers How to use the program ELIAS  to create and modify a 
container 

6 Advanced Features Useful macros, updating from USB stick or CD-ROM, 
overview of the eLux Builder Kit for creating own firmware 

7 Security How to manage certificates and check the validity of packages
8 Commands A reference of ELIAS  menu commands and keyboard 

shortcuts 
 

1.2.1 Commonly-Used Abbreviations 
The following are terms that appear in the manual: 

Abbreviation Description 
FTP File Transfer Protocol 
IP Internet Protocol 
TCP Transmission Control Protocol 

1.3 Finding More Information 
This manual contains conceptual information, and installation and configuration instructions for 
the program ELIAS . Additional information is available from the following sources: 
• The eLux NG and eLux RL Administrator’s Guides for information on the Thin Client 

software eLux NG, which uses the image definition files ELIAS  generates 
• The Scout Enterprise Administrator’s Guide for using the Scout Enterprise software tool to 

manage Thin Clients running eLux NG and eLux RL. 
This guide as well as other ELIAS  documentation is available in Adobe PDF format. It can be 
found in the following locations: 
• The documentation folder on your eLux CD-ROM 
• The product documentation library at www.myelux.com . 
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1.4 Overview 

1.4.1 What is ELIAS?  
The eLux Image Administration Service, or ELIAS, allows you to easily manage the firmware on 
a Thin Client running eLux NG or eLux RL. Each Thin Client comes with a default image 
(recovery.idf) that contains the operating system, software and applications. If you wish to 
change the firmware, you need to create a new image definition file. Using ELIAS, in a new 
image definition file (*.idf) you select exactly those software packages you want installed on the 
Thin Client. These packages are then saved on the flash memory of the Thin Client. The 
administrator can use ELIAS to custom-make the image to satisfy end-user requirements. 

1.4.2 ELIAS  Features 
ELIAS  offers the following features: 
• User-friendly graphical interface that allows you to create software images by a mouseclick 
• Easy management of device firmware using the “container method” 
• Ability to activate/deactivate software components to optimize your use of available 

resources 
• Image size bar to avoid exceeding flash size 
• Automatic proofing of software dependencies 
• Easy import feature to add the latest versions of software 
• Easy export feature that exports a package along with its software dependency information 
• Digital signatures to ensure the installed packages are genuine 

1.5 Understanding a Firmware Update 
When your Thin Client is delivered, it already contains an operating system and basic software: 
Citrix® ICA® client, RDP client, browser, emulations, desktop tools, etc. This allows you to begin 
using your device immediately. 
To modify the firmware (“firmware” = software saved to the flash card), you must perform a so-
called “firmware update”. 
A firmware update has the following steps: 

1. Installing the required programs and files: The program ELIAS  on a computer running 
Microsoft® Windows®, and the Container containing software on a so-called “update 
server” (FTP or HTTP server) 

2. Defining the firmware you want to install on the Thin Client in a so-called “image 
definition file” (IDF) and saving the IDF to the Container on the update server 

3. Configuring the Thin Client with update server’s parameters 
4. Initiating the update, either locally or using the management tool Scout Enterprise. 
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Figure 1: Workflow firmware update 

 
You must create the IDF in advance and transfer the finished IDF to the Thin Client. It is not 
possible to change the firmware online. 
How to install the ELIAS software and define an image definition file is described in the following 
chapters. For information on firmware parameters and how to initiate an update, please see the 
eLux NG / eLux RL Administrator’s Guides or the Scout Enterprise Administrator’s Guide. 
The graphics below clarify the interdependencies and the workflow.  

Figure 2: The image definition file concept 
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1.6 ELIAS Terminology 
This chapter defines terms that are used in this manual. Please read the following before 
continuing. 
 
EPMs and FPMs 
In server-based computing, client software installed on a device is used to connect to server 
software. Examples of client software are an ICA client, RDP client, etc. eLux is module-based. 
In ELIAS, a client program (module) that has been bundled for eLux NG or eLux RL use is 
called a package. 
All packages saved to the flash card of a device are called firmware. 
When updating the firmware saved to a device, you add or delete individual packages. This is 
less time consuming than updating all firmware saved to the device every time you update. 
These software packages are divided into eLux Package Modules (short “EPM”) and Feature 
Package Modules (short “FPM”). An EPM (upper-level package) contains one or more FPMs 
(lower-level package).  
 
Container 
A container is a directory containing the firmware packages for a specific hardware. It contains 
the file “container.ini” which is a text file with important ID information. Each Thin Client model 
has its own container. For example, a Thin Client with an Intel processor has a different 
container than one from National Semiconductor. The container is installed on an FTP or HTTP 
server using the Scout setup, or by hand by downloading individual files from www.myelux.com. 
Please use the default container installation names. 
Note: With eLux RL there is only one Container for all hardware platforms.  
 
Image Definition File 
The image definition file (short “image” or IDF) defines which firmware packages are to be 
installed on a device. The IDF is edited using ELIAS . 
Every IDF must contain a base operating system (OS). Further, you can mix and match 
packages to customize the firmware installed on the device to exactly suit your company’s 
needs. If your device came with software already installed, you can add desired packages or 
delete unwanted packages from the pre-installed image. 
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2 Installing ELIAS  and Container 
This chapter contains the introductory information you need to get ELIAS  running. 
 

Section Description 

2.1 System Requirements Hardware, operating system and access permissions 
needed to run ELIAS  

2.2 Installation Procedure Step-by-step instructions on using the InstallShield Wizard 
tool to install ELIAS  

2.3 Modify, Repair, Remove How to update to a newer version or remove ELIAS  
 

2.1 System Requirements 
ELIAS  has the following minimum system requirements: 
• System: 64-MB main memory 
• Microsoft Windows 2000 and the Windows 2000 family 

Windows XP Professional 
Windows Server 2003 Standard Edition 

• A mounted network drive connection from the PC to the FTP or HTTP server 
• Network authorization 
You must have administrator's authorization for the PC and be connected to a TCP/IP network. 
The container has the following requirements: 
• FTP or HTTP server with write access, installed locally or available on a network drive 
• Space requirements vary depending on the Thin Client hardware platform. Minimum for all 

containers at the time of publishing: 700 MB 

2.2 Installation Procedure 
Installation is performed using the Scout setup program, which is available on the eLux NG CD-
ROM or can be downloaded from the Web site www.myelux.com. 
You have two installation options:  
• Typical Installs Scout Server, Scout Console, ELIAS , Container and Recovery 
• Custom Installs ELIAS  and Container only 
Only ELIAS and Container are needed for the container method.  
To begin the installation procedure, log on to your PC as administrator. If you are using a 
terminal server, please run the setup program from the applet Add/Remove programs in the 
Control Panel.  
Choose the language you want for the installation procedure. This will also be the default 
language of the ELIAS screen elements.  
A setup wizard is provided to guide you through the installation process. 
 
Typical installation procedure: 
To install Scout Server, Scout Console, ELIAS , Container and Recovery 

1. At the welcome screen, click Next. 
2. Read the license agreement and accept to continue. 
3. Click Typical. You can also set the installation directory (by default, 

c:\Program Files\UniCon\scoutng).  



  ELIAS   

Build Nr.: 10  6 

4. Choose the type of server that will be used to access your container. 
5. Enter the path of the FTP or HTTP server root directory (either locally or on a network 

drive) and the fully qualified URL to access the server (format: 
[ftp/http]://<host>). In addition, for FTP enter the logon information (anonymous 
FTP is supported). Examples: 
HTTP server root directory ................................. \\server1\Inetpub\wwwroot\ 
URL .............................................................................http://work.domain.com 
 
FTP server root directory....................... c:\Program Files\Inetpub\ftproot 
FTP.................................................................................. ftp://ftp.domain.com 
User name............................................................................................... anonymous 
Password................................................................................eluxng@domain.com 
The setup program then attempts to verify the values you entered. Note: This may result 
in a delay – please do not click during this time. 
If there are problems contacting the server, an error message appears and you are 
prompted to change your parameters. 

6. If the server was successfully reached, a summary of the components to be installed is 
displayed. Click Next to start copying files. 

 
Custom installation procedure: 
To install ELIAS and Container 

1. At the welcome screen, click Next. 
2. Read the license agreement and accept to continue. 
3. Click Custom. You can also set the installation directory (by default, 

c:\Program Files\UniCon\scoutng). 
4. Select Elias and Container. Click Next. 
5. Choose the type of server that will be used to access your container. 
6. Enter the path of the FTP or HTTP server root directory (either locally or on a network 

drive) and the fully qualified URL to access the server (format: 
[ftp/http]://<host>). In addition, for FTP enter the logon information (anonymous 
FTP is supported). Examples: 
HTTP server root directory ................................. \\server1\Inetpub\wwwroot\ 
URL .............................................................................http://work.domain.com 
 
FTP server root directory....................... c:\Program Files\Inetpub\ftproot 
FTP................................................................................ftp://ftp. domain.com 
User name............................................................................................... anonymous 
Password................................................................................eluxng@domain.com 
The setup program then attempts to verify the values you entered. Note: This may result 
in a delay – please do not click during this time. 
If there are problems contacting the server, an error message appears and you are 
prompted to change your parameters. 

7. If the server was successfully reached, a summary of the components to be installed is 
displayed. Click Next to start copying files. 

 
All required files are installed during the installation procedure, greatly easing the workload for 
the administrator.  
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2.2.1 Default Container Directories 
By default, the container is installed in the FTP or HTTP server root directory under:  
…\eluxng\UC_INTEL_P3 
…\eluxng\UC_GEODE_P1  
…\eluxng\UC_TRANSMETA 
...\eluxng\UC_VIA or 
...\eluxng\UC_PC 

Note: With eLux® RL there is only one container for all hardware platforms.  

 

2.3 Modify, Repair, Remove 
After installation, you can run the setup program at any time to change the components that are 
installed, or update or remove ELIAS. 
Modify: Add or remove single program components. The old setup program will be used. 
Repair: Update the software. A new version of the software is required. 
Remove: Removes all program files, except those that are automatically generated. 
 

2.4 Starting ELIAS  
There are two ways to open ELIAS : 
• Scout Enterprise 

In Scout, go to View menu > Elias.  
• Windows 

From the Windows menu, go to Start menu > Programs > Scout Enterprise > ELIAS. 
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3 Introducing the ELIAS  Interface 
This chapter contains an overview of the ELIAS  main screen. 
 

Section Description 

3.1 ELIAS  Main Screen An overview of the ELIAS  main screen 

3.2 Title Bar A description of the title bar 

3.3 Main Menus A description of the main menus 

3.4 Toolbar A description of the toolbar 

3.5 Container Window An overview of the container window 

3.6 Image Window An overview of the image window 

3.7 Package Information Area An overview of the package information area 

3.8 Icons Display Security Status An overview of the icons 

3.9 Image Size Bar An overview of the image size bar 
 



  ELIAS   

Build Nr.: 10  9 

 

3.1 ELIAS  Main Screen 

Figure 3: ELIAS  main screen 

 
The ELIAS main window has several components, which are described in this chapter: 
• Title bar 
• Main menus 
• Toobar 
• Container window 
• Image window 

• Package Information Area 
• Icons 
• Image Size Bar 

 

3.2 Title Bar 
The title bar at the top of the screen lists the currently opened image definition file. 
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3.3 Main Menus 
The menu bar contains a number of menus that tell ELIAS what to do. Each menu contains a list of 
commands and the equivalent keyboard shortcuts, if available. 

Figure 4: Main menus 

Some of the options carry out commands immediately, and others display a window so that you can 
enter additional information. If an option is followed by "...", it will display a window.  Otherwise, the 
command is carried out immediately. 

3.4 Toolbar 
The toolbar gives you one-click access to commonly used commands. 

Figure 5: Toolbar 

 

This button Does the same as this 
New Image menu > New (see “4.1 Defining a New Image”) 
Open Image menu > Open (see “4.2 Opening an Image”) 
Save Image menu > Save (see “4.5 Saving the Image”) 
Print Image menu > Print (see “4.7 Printing the Image 

Definition File”) 
Help Help menu > Help (see “8.1.5 Help Menu”) 
Import package Container menu > Import package (see “5.3 

Importing Packages into a Container”) 
Export package Container menu > Export package (see “5.4 

Creating a New Container Using the Export Function”) 
Manage certificates Security menu > Manage certificates (see “7.2 

Managing Certificates”) 
Check container signatures Security menu > Check all packages in container 

(see “7.3.4 Checking Signatures of All Packages in a 
Container”) 
Table 1: Toolbar buttons 
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3.5 Container Window 
A container is a directory containing the firmware packages for a specific hardware. It contains the file 
“container.ini” which is a text file with important ID information. Each Thin Client model has its own 
container. For example, a Thin Client with an Intel processor has a different container than one from 
National Semiconductor. The container is installed on an FTP or HTTP server using the Scout setup, 
or by hand by downloading individual files from www.myelux.com. Please use the default container 
installation names )see “2.2.1 Default Container Directories”). 
The Container window contains a list of the packages that make up the content of the container. The 
upper-level packages are eLux Package Modules (EPMs), the lower-level packages are Feature 
Package Modules (FPMs). An EPM (upper-level package) contains one or more FPMs (lower-level 
package).  

Figure 6: Container window 

 
Once you have selected a container (see “5.1 Opening a Container”), the following information is 
displayed in the Container window (right-hand side): 
• Container name The name of the container. If you used default container names when installing, 

the container name is identical to the container ID. 
• Container description By default, the description lists the hardware platform (Intel, Via, Geode, 

etc.) the container may be used for. However, the description is merely a line in the container.ini 
file that can be changed to the text you want. This is useful to document a container that you 
created on your own for a specific purpose, for example, for updating from a USB stick, for a 
specific department in your company, for a specific hardware, etc. For information on how to 
change the container description, see “5.5 Changing the Container Description.” 

• Container path The path of the container directory. This should be identical to the image 
definition file path. 

• Available software packages The software packages in the container. The upper-level packages 
are eLux Package Modules (EPMs), the lower-level packages are Feature Package Modules 
(FPMs). In the Container window, only the EPMs (upper-level packages) are displayed. The EPMs 
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can be added to or deleted from the image definition file. For more information, see “4.3 Adding 
Packages to an Image.” 

3.6 Image Window 
An image definition file (IDF) is a text file. It is a collection of links that describes the packages that are 
to be installed on the flash card. The IDF must be saved to the container directory. 
The Image window contains a two-tier structured hierarchical list of the packages that make up the 
content of the image definition file. If you are familiar with Windows Explorer, you'll find it easy to 
manage the structure. The upper-level packages are eLux Package Modules (EPMs), the lower-level 
packages are Feature Package Modules (FPMs). An EPM (upper-level package) contains one or more 
FPMs (lower-level package).  

Figure 7: Image window 

Once you have created an image definition file (see “4 Defining an Image Definition File”), the 
following information is displayed in the Image window (left-hand side): 
• IDF name The file name. 
• IDF size The size of the image that will be installed on the device. 
• Number of files in IDF The number of files in the IDF. 
• IDF path The path of the IDF. This should be identical to the container path. 
• Defined packages The software packages (EPMs and FPMs) in the IDF. The FPMs can be 

activated or deactivated. For more information, see “4.3 Adding Packages to an Image.” 
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3.7 Package Information Area 

Figure 8: Package information area 

 
When you select a software package (EPM or FPM), the following information is displayed in the 
package information area (at the bottom of the screen): 
• Package name 
• Package version number 
• Package size 
• Number of files in package 
• Signature status 
• Date the signature was last checked 
• Software producer 
• Package description 
 

3.8 Icons Display Security Status 
In ELIAS , software packages (eLux Package Modules [EPMs] and Feature Package Modules [FPMs]) 
are represented by icons.  
The software packages are represented by different icons: 

   EPM: The upper-level packages (EPMs) are represented by certificate icons 

   FPM: (Image window only) The lower-level packages (FPMs) are 
represented by check boxes 

The color represents the security state of the EPM or FPM: 
Green Signature is valid 
Yellow Signature has not yet been checked 
Red Signature is invalid or there was an error during the signature check (missing 

certificate, issuer not yet trusted, etc.) 
For an FPM, the box content represents the selection state (Image window only): 

 Grey Required package. Cannot be selected or deselected. 

 Check Package is selected. Will be installed on the device. 

 Empty Package is not selected. Either will not be installed on the device or if 
already installed will be removed during the next update. 
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3.9 Image Size Bar 
The bar at the bottom of the ELIAS  screen shows an estimate of the image definition file size.  

Figure 9: Image size bar 

 
 

4 Defining an Image Definition File 
This chapter contains detailed information on using ELIAS  to create an image definition file. Defining an image 
definition file consists of selecting packages from the container, transferring them to the Image window, and 
selecting/deselecting individual Feature Package Modules. 
 

Section Description 

4.1 Defining a New Image How to define a new image definition file 

4.2 Opening an Image How to open an existing image definition file 

4.3 Adding Packages to an 
Image 

How to activate and deactivate software components 

4.4 Package Dependencies How ELIAS  accounts for package dependencies 

4.5 Saving the Image Rules for saving an image definition file to the container 
directory 

4.6 Size Constraint How to avoid exceeding available flash memory size 

4.7 Printing the Image Definition 
File 

How to print a hardcopy of the image definition file 
contents 
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4.1 Defining a New Image 
To define a new image, in the Image menu select New. 

4.2 Opening an Image 
To modify an existing image, in the Image menu select Open and browse for the desired IDF. 

Tip The default recovery images are automatically installed in the container. You can use these as a 
template. Open and save under a new name (always keep a copy of the original for backup purposes). 
For a list of default container directories, see “2.2.1 Default Container Directories.” 

4.3 Adding Packages to an Image 
To add packages to an image, do the following: 

1. Open a container (see “5.1 Opening a Container”). 
2. Select a package in the container window and click the left arrow. The package appears in the 

image window.   
ELIAS  tests your selection for incompatibilities and will warn you if two packages conflict. In 
addition, if a package you select is dependent on another package, you will be prompted with 
a message and requested to select the other package first. This insures that there are no 
software incompatibilities in the finished IDF. 
Tip: Select a package in the image window and click the right arrow to remove the package. 

3. Every EPM contains one or more Feature Package Modules (FPMs). In the image window, 
click on the + in front of an icon to expand the software package and display the FPMs 
contained in this EPM. The FPM icons may be grey, check mark or empty: 
Grey: Mandatory feature which cannot be deactivated 
Check mark: Optional feature which has been activated 
Empty: Optional feature which has been deactivated 

 

Tip For a description of icons and their meanings, see “3.8 Icons Display Security Status.” 

 
4. Activate or deactivate a feature by selecting it and pressing the space bar. You can also use 

the context menu by clicking with the right mouse button. 
 

Tip The packages required by a specific feature are listed in the chapter for that feature in the 
eLux NG Administrator’s Guide and Scout Enterprise Administrator’s Guide. 

 
Additional information 
• When you add packages to an IDF, ELIAS  tests for software incompatibilities. It cannot, however, 

check for hardware incompatibilities! This is left up to the administrator. 
• The first package that must be selected is the base OS. This is the core of the IDF. 
• Next, select software required in your server-based computing network: Citrix® ICA®, RDP, 

browser, emulation, SAP. 
• Further software is included to eLux NG or eLux RL users at no additional charge: desktop tools, 

VNC server, mirroring software, FreeS/WAN VPN. 
• Other software must be licensed: X32/52 and X97 emulations, third-party software, etc. 
 
Due to the fact that the software is hardware dependent, you may not have the software listed above 
in your container. In addition, the above list is not all-inclusive. Currently available packages can be 
downloaded from www.myelux.com. 
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4.4 Package Dependencies 
Some packages are dependent on others. For example, all packages require a base operating system 
(base OS), so the first package you must select is the base OS. ELIAS  automatically checks for 
dependencies when you select a package. For example, if you try to install a browser before installing 
an operating system, you get the following error message:  

Figure 10: ELIAS  error message 

4.5 Saving the Image 
To save your image definition file, from the Image menu click Save.  
 
Follow the following rules when saving an image definition file: 
• Save the image definition file to the container directory. 

For a list of default container directories, see “2.2.1 Default Container Directories.” 
• The name must not contain a blank. 
• Use a transparent naming scheme for the image definition file. Recommended is a name that will 

remind you in the future of the firmware it contains and the size, for example, “sap128.idf” for a 
128-MB large image with the SAP client. 

• If you save your files using the pre-set text “small” (32 MB), “medium” (96 MB), “large” (128 MB) or 
“XXL” (250 MB or higher), you can take advantage of the built-in macro. See “6.1 SIZE Macro” for 
more information. 

4.6 Size Constraint 
During the image definition process there is no total size restraint. The total image size can exceed the 
actual flash memory size, allowing you to experiment with different software combinations, activating 
or deactivating software components until you have met your requirements. However, the final image 
cannot exceed the total flash size. Please be aware of this when saving your files. 
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4.7 Printing the Image Definition File 
For documentation purposes, ELIAS  lets you print a list of the software packages and features in an image 
definition file. In the Image menu, Print, Print Preview and Print Options allow you to configure the print 
settings.  
Figure 11 shows an example of the Print Preview command. 

 

Figure 11: Print Preview of the image definition file 
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5 Working with Containers 
This chapter contains information on using ELIAS  to manage a container. 
 

Section Description 

5.1 Opening a Container How to open a container 

5.2 Downloading Packages from 
the Internet 

How to download software packages from 
www.myelux.com 

5.3 Importing Packages into a 
Container  

How to import software into a container  

5.4 Creating a New Container 
Using the Export Function 

How to generate a new, customized container using the 
Export function 

5.5 Changing the Container 
Description 

How to change the container description 

5.6 Deleting Packages from a 
Container 

How to permanently delete packages that are no longer 
needed from a container 

5.1 Opening a Container 
If you used the default container directory names during installation, ELIAS  will automatically open the 
container upon start. For a list of default installation directories, see “2.2.1 Default Container 
Directories.” 
If you did not use default settings, you must select a container. 
To select a container, in ELIAS click Select in the Container menu and browse for your container. 
When the container directory has been located, open the file “container.ini” it contains. 

5.2 Downloading Packages from the Internet 
New software packages can be downloaded from the Internet. You must complete a free one-time 
registration. 

 To download software packages from the Internet 
1. Go to the Web site www.myelux.com. 
2. In the navigation links on the left-hand side, click “Login.” 
3. If you have not yet registered, click “Registration” and follow the instructions. You will receive 

your login and password in one to three days. Otherwise enter your login information and click 
“Submit.” 

4. The main page is displayed with a “Download” and “Service” area. Click “eLux software 
packages.” This opens the “Available containers“ page. 

5. Under “eLux NG”, locate your hardware platform and click on the link in the column under 
“Released packages.” 

6. The container page lists the container ID and the hardware platform. As containers are 
hardware specific, please verify that you have selected the correct container.  
Other important information that is displayed is the the release date and the last time the 
software was updated, the version of Scout and ELIAS that should be used, and the supplier. 
In addition, you can view a list of supported hardware components. 

7. Locate the individual package to download (the product name is listed in the right-hand 
column list) and save it to a directory on the machine with the container. 
Warning: Do not save it directly to the container. 

8. When the transfer is complete, follow the instructions for importing packages into a container 
in “5.3 Importing Packages into a Container.” 
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5.3 Importing Packages into a Container 
A container is a collection of software packages. The administrator chooses a subset of this pool of 
packages to install on the Thin Client when defining an IDF.  
In normal use, it is not necessary to change the packages in a container. Packages that are not 
needed have no effect. 
However, at times it is necessary to update the container when: 
• New client software is available (Citrix® ICA®, RDP, emulation, etc.) 
• A new base OS is released (eLux) 
• A software bug is fixed 
 

 To import an individual package in a container 
1. Follow the instructions for logging on to www.myelux.com in “5.2 Downloading Packages from 

the Internet.” 
2. When transfer is complete, run ELIAS . Select your container (Container > Select). 
3. In the Container menu, select Import package. Browse for the *.zip file you just downloaded. 

When you have located it, click Open. 
The Import Package function allows you to either import a new software package into a container or 
overwrite existing packages. The features and software dependencies of every software package 
remain intact. 

Warning To insure error-free functionality, packages should only be imported into a container using 
the ELIAS  Import function! If you copy packages directly into a container directory not using ELIAS , 
essential software dependencies and components will be lost. 

 

5.4 Creating a New Container Using the Export Function 
 

Tip You can update from a portable storage device, such as a USB stick or a CD-ROM. This is 
described in the eLux NG / eLux RL Administrator’s Guides and Scout Enterprise Administrator’s 
Guide. This section describes how to create a smaller container that fits on the portable storage 
device. See also “6.3 Updating from File.” 

 
You can construct a new customized container using the Export Package function. This is useful when 
updating from a USB device with limited memory. 

1. Create a new directory. Copy the file container.ini from your container to this new 
directory. 

2. Run ELIAS . Select your container (Container > Select). 
3. In the container window, click to select a package. 
4. In the Container menu, select Export package. Browse for the new directory you just 

created. When you have located it, click Save. Do not change the standard file name. The 
package you selected will be saved to this new directory. 

5. Repeat until you are finished.   
 
To differentiate between containers, store them in different directories and label the directories by 
hardware type. Please be aware that you must use standard container names to take advantage of 
the container macro. For more information on the container macro, see “6.2 CONTAINER Macro.”  
As with the Import function, all features belonging to a software package are automatically included. 
To insure all subcomponents are exported, please use the Export Function and not Windows Explorer. 

5.5 Changing the Container Description 
If you create a customized container, you should change the description to describe the new 
container. 
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 To change the container description 
1. Start Windows Explorer and go to the container directory. 
2. Open the file “container.ini” using Notepad. 

You should see something similar to the following: 
 

[Global] 

ContainerID=UC_INTEL_P3-1.0-1 

ContainerDescription=eLux NG Container for Intel Pentium III 

 
3. For the “ContainerDescription” value enter a new description of your choosing and save the 

file. 
4. The next time you open the container in ELIAS , this new container description will be 

displayed in the container window. 

Warning Do not alter the container ID. 

5.6 Deleting Packages from a Container 
To remove outdated software from your container, you need to delete its package. To delete a 
package from a container, open the container in ELIAS (Container > Select). Select the software 
package you wish to delete and press the DEL key or click with the right mouse button > Delete.  
A confirmation dialog box appears, informing you of the software packages that will be affected. Click 
Yes to delete the package irretrievably. 
 

Warning Package deletion is irreversible! Before deleting a package, check that the package is not 
used by any image definition file (*.idf). Once you delete a package, it cannot be restored. 
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6 Advanced Features 
This chapter contains information on advanced functionality.  
 

Section Description 

6.1 SIZE Macro Discussion of the macro for automatic recognition of flash 
size 

6.2 CONTAINER Macro Discussion of the macro for automatic recognition of device 
hardware 

6.3 Updating from File Overview of updating from a USB stick or CD-ROM 

6.4 eLux Builder Kit Overview of the eLux Builder Kit 
 

6.1 SIZE Macro 
The SIZE macro allows you to consolidate the image definition file name into one parameter. This 
greatly eases configuration in networks with different sized flash cards. 
The device hardware is automatically detected during the recovery process. The text “__SIZE__” in 
the name of the image definition file will automatically be replaced with text corresponding to the size 
of the Thin Client’s flash card as follows: 

 

Text Flash size (MB) 
“small” 32 
“medium” 96 
“large” 128 
“xxl” 256 or greater 

Table 2: SIZE macro 

 
To use the SIZE macro, the administrator creates image definition files for the flash card sizes in the 
network. (The IDF size is displayed in ELIAS  when the IDF is being created. The size of the IDF must 
equal to or less than the size of the flash card.) The naming scheme is important: It must be a root with 
the text listed in the table above. Format: <root><macro text>.idf 
 
Example 
Assume the administrator of “Company 1” wants to update all Thin Clients in a network containing 
devices with 32-, 96-, 128- and 256-MB sized flash cards. The administrator creates four IDFs in 
advance using the following naming scheme: 

 

IDF name IDF size (MB) 
“company1small.idf” 32 
“company1medium.idf” 96 
“company1large.idf” 128 
“company1xxl.idf” 256 or greater 

Table 3: Examples of SIZE macro 

and saves all four IDFs to the appropriate container.  
On each device in the Image file field of the Firmware tab, the administrator enters one parameter: 
company1__SIZE__.idf.  
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During the update, if a 32-MB flash card is detected, the IDF “company1small.idf” will be installed, if a 
96-MB flash card is detected, the IDF “company1medium.idf” will be installed, etc. If a hard disk is 
detected, the IDF “company1xxl.idf” will be installed. This only works if the IDF actually exists and has 
the required name. 
Conclusion 
Using the SIZE macro is not mandatory. As administrator, naturally you can replace this text with the 
actual name of the recovery IDF. In this case, you lose the dynamic recognition of the macro.  

6.2 CONTAINER Macro 
The CONTAINER macro allows you to consolidate the image definition file path into one parameter. 
This greatly eases configuration in networks with more than one hardware platform. 
The device’s hardware is automatically detected during the recovery process. The text 
“__CONTAINER__” in the Path field of the Firmware settings will automatically be replaced with the 
default container name for that hardware as follows: 

 

Text Chipset 
“UC_INTEL_P3” Intel  
“UC_GEODE_P1” Geode 
“UC_TRANSMETA” Transmeta 
“UC_VIA” Via 
“UC_PC” Pentium MMX 

processor or higher 
Table 4: CONTAINER macro 

 
All chipsets in the above table refer to thin clients, except “UC_PC”, which refers to personal 
computers. 
 
A few words about eLux for PC 
eLux for PC is eLux software that has been adapted to run on PCs. This software enables you to 
transform the PC into a fully functional terminal for a server-based computing environment. This allows 
you to "recycle" old, worn-out computers and save money. 
Test the software using the “eLux for PC Live” CD (ISO image available for download at 
www.myelux.com to be burned to a CD or see your distributor). This is evaluation software that boots 
directly from CD without installing anything on your hard disk. It is possible to use your network 
(Ethernet) and to set up a server connection. It is not possible to save setup data or a configuration file 
to the CD-ROM or elsewhere. This software is for evaluation purposes only. 
After evaluating the software running from CD, if you decide you want to install it on your hard disk, 
click the "Install" button. Initially, the software will run in demo mode. End demo mode by purchasing a 
license. For purchasing information, see our list of qualified partners at www.myelux.com.  
Supported hardware: Pentium I-MMX and higher, min. 64 MB RAM, min. 128 MB hard disk, PCI video, 
PCI LAN. ISA LAN and ISA video are not supported. eLux NG for PC can only be installed on IDE or 
Intel 915 SATA hard disks. SCSI hard disks are not supported. There is no technical support for 
hardware drivers! All hardware drivers have to be verified by the evaluation CD –  network, graphic, 
sound. If the evaluation CD runs on your PC, eLux for PC can be installed. 
Example 
Assume the administrator wants to update all Thin Clients in a network. The Thin Clients have different 
hardware. The administrator creates the required IDFs in advance and saves them to the appropriate 
containers. In the Path field of the Firmware tab, the administrator enters one parameter: 
eluxng/__CONTAINER__ 
During the update, the container path “eluxng/UC_INTEL_P3” will be used if an Intel chipset is 
detected, the container path “eluxng/ UC_GEODE_P1” will be used if a Geode chipset is detected, etc. 
 
Conclusion 
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For this macro to work, you must use containers with standard installation names.  
Using the CONTAINER macro is not mandatory. As administrator, naturally you can replace this text 
with the actual name of the container. In this case, you lose the dynamic recognition of the macro. 

6.3 Updating from File 
You can perform an update locally using direct file access to a container on a USB stick or a CD-ROM.  
Create an IDF as described in “4 Defining an Image Definition File” and save it to the container. Copy 
the entire contents of the container (including IDF) to the memory stick or CD-ROM. Note: You may 
have to reduce the size of the original container. This can be done either by creating a new container 
(see “5.4 Creating a New Container Using the Export Function”) or removing packages (see “5.6 
Deleting Packages from a Container” – be sure to keep a copy of the original container for backup 
purposes).=
This topic is beyond the scope of this manual. For more information on restrictions, firmware 
parameters and special considerations, see the eLux NG / eLux RL Administrator’s Guides or the 
Scout Enterprise Administrator’s Guide. 

6.4 eLux Builder Kit 
The eLux Builder Kit (EBK) for Linux is a development environment for skilled Linux developers or 
administrators to create their own software packages. The resulting packages can then be added to an 
IDF using ELIAS . This allows you to install your own software, such as special drivers, on the flash 
card.  
Creating a package can be understood as a translation process in which package specifications and 
binary files (for example, programs, libraries) are compiled into an eLux NG package, which can then 
be made available on the update server. 
This tool is provided free of charge. For more information, see the Web site www.myelux.com.  
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7 Security 
This chapter contains information on how to manage certificates and check the validity of packages. The security 
features described in this chapter are available starting with ELIAS version 6.0 and eLux NG version 1.14 as well 
as eLux RL.   
 

Section Description 

7.1 Understanding   A short primer on trust hierarchies 

7.2 Managing Certificates How to work with certificates, import a new certificate and 
set certificate check configuration settings 

7.3 Checking Package Validity How to check the validity of package signatures and set 
signature check configuration settings 

 

7.1 Understanding Digital Certificates 
The ISO X.509 protocol defines a mechanism called a digital certificate that contains a user’s public 
key and has been signed by a trusted entity called a Certificate Authority (CA). 
The certificate is used to identify an EPM or FPM (“the package is signed with the certificate”). 
A certificate contains the following information: 

• Issuer The organization that issued the certificate 
• Subject The party that is identified by the certificate 
• Period of validity The certificate’s start date and expiration date 
• Public key The subject’s public key used to encrypt data 
• Issuer’s signature The CA’s digital signature on the certificate used to guarantee its authenticity 

 
The following types of digital certificates are required by ELIAS: 

• Trusted issuer 
• Intermediate issuer 
• Root certificate 

This identifies the CA that signed the trusted issuer certificate. The root certificate belongs to the 
CA. A root certificate is required to verify the authenticity of trusted issuer and intermediate 
issuer certificates 

 
ELIAS  ships with built-in support for the following root certificates: 
• TC TrustCenter Class 3 CA 

 
If you use a certificate signed by a different CA, you will have to import that CA’s root certificate in 
addition to the certificate itself. 
For use in security, the certificate must be valid. Certificates are valid only for a specified time period; 
when a certificate expires, a new one must be issued. The issuing authority can also revoke 
certificates. Before you trust a certificate, make sure that the certificate has not been revoked. 
The list of all certificates currently entered in ELIAS is called the “trusted list.” ELIAS checks the 
validity of the signatures of software packages against the certificates currently in its trusted list. 
Expired certificates are automatically marked red and can no longer be used for verification. ELIAS  
also provides online OCSP check capabilities to check the validity of the certificates in its trusted list.  
 



  ELIAS   

Build Nr.: 10  25 

 

7.2 Managing Certificates 
This section describes how to manage the certificates in ELIAS’s trusted list.  

7.2.1 Viewing certificate information 
You can use ELIAS  to view the information in a certificate. 

Figure 12: Manage certificate dialog box 

 
 To view certificate information 

1. In the Security menu, select Manage certificates. Alternatively, click on the corresponding 
button in the toolbar. 
The Manage certificates dialog box appears, displaying the list of trusted certificates. 

2. Go to the desired tab. 
3. Either double-click a certificate or select a certificate and click Details.  

The Certificate dialog box appears. 
General Displays issuer, recipient and period of validity. 
Details Displays certificate information. 
Certification path Displays the certification path. Click on the plus to expand. 

4. When you are done, click OK to close the dialog box. 
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7.2.2 Setting OSCP settings 
An Online Certificate Status Protocol (OCSP) server is used to check the status (valid, revoked, 
unknown) of a certificate. 

Figure 13: OCSP settings 

 
 To set OSCP settings 

1. In the Security menu, select Settings. 
2. In the Security settings dialog box, enter the following: 

Proxy server (optional) If you use a proxy server to connect to the Internet, enter the proxy 
server IP address (or name) and the port. 
OCSP server In general, the OCSP server is automatically read from the certificate. If this 
information is not available, you can enter a default OCSP server in URL format and the port 
by hand. Format: http://<OCSP server URL> 
Default values are http://ocsp.openvalidation.org and 80. 
OCSP check within package verification Every time before checking a signature, the 
validity of the certificate will automatically be checked. For information on checking signatures, 
see “7.3 Checking Package Validity.” 

3. Click Apply. 
 

7.2.3 Checking a certificate manually 
You should periodically check the validity of certificates in the trusted list by performing an OCSP 
check. An Internet connection is required. 
 

 To check the validity of a certificate 
1. Set the OCSP settings, if you have not already done so. For more information, see “7.2.2 

Setting OSCP settings.” 
2. In the Security menu, select Manage certificates. 
3. In the Manage certificates dialog box, go to the desired tab and click to select a certificate. 
4. Click Verify. 

The Online verification dialog box appears. Verification takes place. 
5. When the process is done, a status message are displayed. If verification failed, check that 

OCSP settings are correct (step 1). 
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7.2.4 Deleting a certificate 
In ELIAS , all certificates entered in the trusted list are considered trustworthy. If a certificate is no 
longer trustworthy, it should be deleted. 
To delete a certificate, click to select Security > Manage certificates. Go to the desired tab and click 
to the select the desired certificate. Click Delete. 

7.2.5 Importing a certificate 
To enter a certificate in ELIAS , it must be imported. You can import a root CA, intermediate CA or 
trusted CA. The certificate must be in *.cer or *.pem format and available in the local network.  

 To import a certificate in ELIAS  
1. Save the certificate to a temporary folder. 
2. In ELIAS, in the Security menu, select Manage certificates. 
3. In the Manage certificates dialog box, go to the desired tab and click Import. 
4. Browse for the certificate. 

7.2.6 Exporting a certificate 
Use the export function to copy a certificate to another destination. A copy of the certificate remains in 
ELIAS .  

 To export a certificate from ELIAS  
1. In the Security menu, select Manage certificates. 
2. In the Manage certificates dialog box, go to the desired tab and click to select a certificate. 
3. Click Export. 
4. Browse for the desired directory and click Save. 

7.3 Checking Package Validity 
When you use firmware signed by UniCon Software GmbH, you can be sure that the firmware comes 
from UniCon Software and not from a suspect third-party. You can rest assured that the software you 
install on your devices is legitimate and not a security hazard.  
This section describes how to check the signatures of firmware. By default, ELIAS  comes with a 
preinstalled trusted certificate. For information on importing and managing certificates, see “7.2 
Managing Certificates.” 

7.3.1 Configuration settings for checking package signatures 
By default, the validity of a package’s signature is checked internally against the trusted list. In 
addition, you can configure ELIAS  to check the status of the involved certificates first (OCSP check). 
An Internet connection is required. 

 To configure ELIAS  to perform an OCSP check on package signatures 
1. In the Security menu, select Settings. 
2. In the Security settings dialog box, enter the proxy server and a default OCSP server. For 

more information, see “7.2.2 Setting OSCP settings.” 
3. Click to select OCSP check within package verification. 
4. Click Apply. 

 
From now on an additional OCSP check of the involved certificates will be performed online before a 
package signature is checked. 

7.3.2 Checking Signatures upon Import 
To automatically check the signatures of firmware (EPMs and FPMs) that are imported, click to select 
Security > Check signature during import. It is a toggle. Click to deselect to deactivate this feature. 
By default, the validity of a package’s signature is checked internally. To perform an additional OCSP 
check, see “7.3.1 Configuration settings for checking package signatures.” 
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7.3.3 Checking Signature of a Single Package 
Checks the signature of a single package. If the package is in the: 

Container window Checks the EPM and its corresponding FPMs. 
Image window Checks either the EPM and its corresponding FPMs or a single FPM, 

depending on what you select. 
 

 To check the signatures of a selected package 
1. Click to select a package and go to Security menu > Check selected package or click with 

the right mouse button on a package and select Check selected package. 
2. The signatures of all FPMs in the selected EPM are checked. 
3. When the process has finished, the Check signature dialog box appears. 

Figure 14: Checking package signature for base OS 1.12-2 

• Error The signature is incorrect. For a list of common error messages, see “7.3.6 
Troubleshooting.” 

• Signature valid The signature is correct 
This information is also displayed in the ELIAS  main screen under “Package information” > 
“Status” when you select the package. 

The validity of a package’s signature is checked using the internal list of certificates. To perform an 
OCSP check on the certificate list, see “7.3.1 Configuration settings for checking package signatures.” 

7.3.4 Checking Signatures of All Packages in a Container 
 To check the signatures of firmware in a container 

1. In the Security menu, select Check all packages in container. Alternatively, click on the 
corresponding button in the toolbar. 

2. The signatures of all firmware (EPMs and FPMs) are checked. 
3. When the process has finished, the Check signature dialog box appears. 

• Verification failed The signature is incorrect 
• Signature valid The signature is correct 

Tip Double-click on an EPM to display the signature status of its FPMs. For a list of common 
error messages, see “7.3.6 Troubleshooting.” 
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The validity of a package’s signature is checked using the internal list of certificates. To perform an 
OCSP check on the certificate list, see “7.3.1 Configuration settings for checking package signatures.” 
 

7.3.5 Signature and certification information 
A helpful diagnostic tool is the Signature and certification information dialog box. If the package is 
in the: 

Container window Checks the EPM and its corresponding FPMs. 
Image window Checks either the EPM and its corresponding FPMs or a single FPM, 

depending on what you select. 
 

 To view the security status of a software package 
1. Click to select a package and go to Security menu > Check selected package or click with 

the right mouse button on a package and select Signature and certification information. 
2. The security status of the individual EPMs and FPMs in this package is displayed. 
3. Click to select an FPM. A variety of information is displayed. 

• Check again The signature of the selected FPM is checked again. For information on 
settings, see “7.3.1 Configuration settings for checking package signatures.” 

• Details Displays information on the certificate used in this check. Also available by 
double-clicking on the package. For more information on the Certificate dialog box, see 
“7.2.1 Viewing certificate information.” Deactivated if no signature file is present. In this 
case, update the container to the latest software. 

Click with the right mouse button on a package in the dialog to access these commands from 
the context menu. 

 
In addition, in the ELIAS  main screen, click on a package in the Image window or Container window. 
Its security status (including any error message) is displayed in “Package information” > “Status”. 
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7.3.6 Troubleshooting 
Following is a list of common error messages. 
 

Error message Action 
[Error 21] Issuer not in the 
trusted list 

The required trusted issuer certificate is missing.  
While the check is in progress, the dialog “Should the issuer 
be trusted?” appears. Click Yes.  
Alternatively, download the required certificate from 
www.myelux.com and import it to the trusted list. See “7.2.5 
Importing a certificate.” 

[Error 22] Root certificate 
cannot be found  

The required root CA certificate is missing. 
In ELIAS, click to select the package. In the Security menu, 
select Signature and certification information. Double-click 
the package. The Manage certificates dialog box appears. 
Go to the Certification path tab to see which certificate is 
missing. 
Download the required certificate from www.myelux.com and 
import it into the trusted list. See “7.2.5 Importing a 
certificate.” 

[Error 30] Certificate expired The certificate has expired.  
Download the required certificate from www.myelux.com and 
import it into the trusted list. See “7.2.5 Importing a 
certificate.” 

[Error 40] Intermediate 
certificate cannot be found 

The required trusted intermediate CA certificate is missing. 
In ELIAS , click to select the package. In the Security menu, 
select Signature and certification information. Double-click 
the package. The Manage certificates dialog box appears. 
Go to the Certification path tab to see which certificate is 
missing. 
Download the required certificate from www.myelux.com and 
import it into the trusted list. See “7.2.5 Importing a 
certificate.” 

[Error 43] Certificate revoked The certificate was revoked. Do not trust this issuer! 
[Error 103] No signature file 
found 

The signature file is missing. Download the latest version of 
the container or firmware packages. 

[Error 130] Connection failed Could not connect to the OCSP server. 
Go to the Security settings dialog box (Security > 
Settings). 

• If you have an Internet connection, verify proxy 
settings. 

• If you do not have an Internet connection, deactivate 
the OCSP check within package verification check 
box. 
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8 Commands 
These chapters are meant as a reference guide for the various menu and keyboard commands. Cross references 
to more detailed information elsewhere in the manual is provided where appropriate.  
 

Section Description 

8.1 Main Menus Description of the main menu commands: Image, 
Container, Security, View, Help 

8.2 Keyboard Shortcuts Useful key combinations for often used functions 
 

8.1 Main Menus 

8.1.1 Image Menu 
Image > New 
Opens a new image definition file.  

Image > Open 
Opens a pre-existing image definition file. 

Image > Save, Save As 
Saves the current image definition file. 

Image > Print, Print Options 
Opens the Print Options dialog box. It’s appearance 
may be different depending on your operating 
system. Allows you to set the printer, paper and 
format settings. 

Image > Print Preview 
Displays a list of the software packages contained in the 
image definition file to be printed. See section “4.7 
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Printing the Image Definition File.” 

Image > <image definition file> 
A list of the most recently opened image definition files for one-click access. 

Image > Exit 
Closes ELIAS . 

8.1.2 Container Menu 
Container > Select 
Browse to select a container. 

Container > Import Package 
Imports a package into a pre-existing container. After receiving a new package, either from your 
distributor or from the Web, you must import it into a container before you can add it to an image 
definition file.  

Container > Export Package 
Export a package to another location. For example, if you receive a new version of Netscape and want 
to make it available to all your branch offices, export it to their container directories, which may lie on 
other HTTP or FTP servers. 

Container > <container name> 
A list of the most recently opened containers for one-click access. 

8.1.3 Security Menu 
Security > Check signature during import 
When selected, signatures will automatically be 
checked when packages are imported. 

Security > Check all packages in container 
Checks the signatures of all packages in the 
container. See “7.3.4 Checking Signatures of All 
Packages in a Container.” 

Security > Check selected package 
Checks the signature of a selected package and its components in either the Container window or 
Image window. See “7.3.3 Checking Signature of a Single Package.” 

Security > Signature and certification information 
Displays the security status of a package and its components selected in either the Container window 
or Image window. See “7.3.5 Signature and certification information.” 

Security > Manage certificates 
Allows you to manage the certificates in ELIAS ’s trusted list. 

Security > Settings 
Enter configuration settings for online OCSP check. 

8.1.4 View Menu 
View > Toolbar 
When selected, displays the toolbar. 

 
The toolbar icons allow one-click access to the following commands: New, Open, Save, Print, Help, 
Context-Sensitive Help, Import package, Export package, Manage certificates, Check signatures of all 
packages in container. 
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8.1.5 Help Menu 
Help > Help 
Opens ELIAS  Help Topics. Keyboard shortcut: F1. 

Help > About ELIAS 
Displays the name and version number of the software. 

8.1.6 Image Window 
Image window context menu:  

Activate/Deactivate: Activate or deactivate this FPM. 
Check selected  Checks the signature of a selected package and its components in either the 
package:  Container window or Image window. 
Signature and  
certification  Displays the security status of a package and its components selected in 
information:  either the Container window or Image window. 
 

8.1.7 Container Window 
Container window context menu:  

Check selected  Checks the signature of a selected package and its components in either the 
package:  Container window or Image window. 
Signature and  
certification  Displays the security status of a package and its components selected in 
information:  either the Container window or Image window. 
Check all  
packages in  
container: Checks the signatures of all packages in the container 
Delete package:  Removes this package from the container. 
 

8.1.8 Signature and Certification Information Dialog Box 
Signature and Certification Information dialog box:  

Details:  Displays information on the certificate used in this check. 
Check package  
new:  The signature of the selected package is checked again. 

 

8.2 Keyboard Shortcuts  
 

Key Combination Action 

General  

Cursor (arrow) keys: 
  

Screen navigation 

F1 Opens online help. 

TAB / SHIFT-TAB Screen navigation 

Container Window  

CTRL + left arrow key: 

 

Adds a package to the IDF. 
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DEL Deletes the selected package from a container 

INSERT Opens the Import Package dialog box. 

Image Window  

Cursor (arrow) keys: 
   

Expands / collapses a defined upper-level eLux Package Module 

CTRL + right arrow key: 

 

Removes a package from the image definition file. 

SPACE BAR 1. Expands / collapses a defined upper-level eLux Package Module 
2. Activates / deactivates a lower-level Feature Package Module 

 
Further shortcut keys are adjusted to default Windows shortcut keys. 
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